How To Install Photoshop Plugins in Paint.NET

namesuppressed's graphic effects plugins work with Paint.Net, a free image editor program for Windows available from GetPaint.Net. This tutorial will shows you how to get plugins installed and working it.

What you'll need

Before you can use Photoshop plugins with Paint.NET, you need to download and install the "PSFilterPdn PSFilterShim", and also get some plugin effects to play with.

How to install the PSFilterPdn PSFilterShim

  1. Find the zip file you downloaded above called PSFilterPdn.zip. When you find the file, double click on it to open the zip file and find a folder with two files in it:

    The two files psfilterpdn.zip and psfiltershim.exe are in the zip file.

  2. You need to copy these two files (PSFilterPdn.DLL and PSFilterShim.exe) into your C:\Program Files\Paint.NET\Effects\ folder on your hard drive. You can get to your C: (Local Drive) from the My Computer link in the Start Menu:

    The location of the My Computer link in the Windows XP Start Menu.

    And copy the two files into the Effects folder below:

    The location of the Effects folder in Paint.NET installations.

  3. All done. The next time you start Paint.Net, you should see an "8BF Filter..." command at the bottom of your Effects menu. This is what you click on to start Photoshop plugin effects.

    Where the 8BF Filter menu option appears in Paint.NET.

Setting up Photoshop Plugins in Paint.NET

  1. Once PSFilterPdn is installed, you need to tell it where to find the Photoshop plugins on your computer. Click on the "8bf Filter" command in your Paint.NET Effects menu, and you'll get a screen like this:

    The Paint.NET 8BF Filter interface window

  2. Click on “Search Directories” at the top of the window, and then click “Add...” to launch the Browse For Folder window. You then need to add all the folder / directories where you have Photoshop plugins installed. For namesuppressed plugins, start by adding C:\Program Files\namesuppressed\ and making sure that Search Subdirectories is checked.

    The browse for folder window in the 8BF Filter of Paint.NET.

  3. Now click on the Filters tab again at the top of the window. You should now find all your Photoshop plugins listed. Just click on the effect plugin you want to use, and then click “Run Filter”. All done!



<< back to the Support index