How to install Photoshop Plugins in Photoshop

There are a couple of ways to install plug-ins into Photoshop:

Run the plugins installer

Most Photoshop plugins now come with an installer that automatically finds your Photoshop plug-ins folders and installs the plugin for you. You should always try running the installer program first and letting it do the work for you.

Photoshop plugin installer autodetecting folders

Find your Photoshop plug-ins folder manually

If your plugin comes as a zip file, you'll need to open it and copy the 8BF plug-in file manually into your Photoshop plug-ins folder.

If you're using Photoshop CC (eg version 2013 - 2017 or later) on Windows, your Photoshop plug-ins are stored in a folder shared between all Photoshop CC versions:

C:\Program Files\Common Files\Adobe\Plug-ins\CC

For older versions of Photoshop, the plug-ins folder is a sub-folder of your Photoshop folder, so if you can find where Photoshop is installed, you can find the folder. It's usually something like:

C:\Program Files\Adobe\[Photoshop Version here]\Plug-ins\

If you’re having trouble finding it, click on the “Search For Files Or Folders” option in your Windows Start menu. Then do a search for files or folders named “Plug-ins” (make sure you spell it as typed here, without the quotes). You should get a list of folders, and one of them is your Photoshop plug-ins folder.

Once you’ve found your plug-ins folder, try installing the plug-in again. Most installers have a screen that let you choose an extra folder to install the plug-in into. You should choose the Photoshop plug-ins folder you found above. The next time you run Photoshop, the plug-in should be listed in your Filter menu.

Photoshop plugin folder install screen
 

Adding an additional Photoshop plug-ins folder

If you have Photoshop CS6 (or earlier), you can make Photoshop look in an extra second folder where you have installed other plugins. In Photoshop, choose the Edit -> Preferences -> Plug-Ins & Scratch Disks menu option.

Photoshop Plug-In Preferences menu option

On the next screen, make sure that the Additional Plug-Ins Folder option is checked. Then click on the Choose button, and browse for the folder where your Photoshop plug-ins were installed.

Photoshop Plug-In Preferences menu option

You can use this option to point to a plug-ins folder that is shared between all the graphics programs on your computer. You could try using the official shared Photoshop CC plugins folder:

C:\Program Files\Common Files\Adobe\Plug-ins\CC

You’ll now need to quit Photoshop and restart it. The next time you run Photoshop, all compatible plug-ins in that folder should show up in your Filter menu.

Still not showing up in the menu?

Try this: What to do if the Photoshop plugin doesn't show in the Filter menu.



<< back to the Support index