The Photoshop plugins aren't in my Filter menu.

Make sure you're looking in the right place! Our plug-in filters usually appear in the Filters -> namesuppressed menu (in Photoshop), or Effects -> Plug-in Filters -> namesuppressed menu (in Paint Shop Pro). If you have lots of plug-ins installed, you may find it in a sub-menu called “Other” instead of “namesuppressed”.

Photoshop Filter Menu

Are the plugins installed correctly?

If the plug-in isn't there, it might not be installed in the right folder. Photoshop plug-ins must be installed in your program's Photoshop Plug-ins folder. The installer should find the right folder automatically, but if not, click on the name of your graphics program for more instructions:

If you have several graphics programs on your computer, and you want your Photoshop plugins to work with all of them, you should setup a shared plug-ins folder. Try reading our instructions for using Photoshop Plugins in multiple programs at once. .

Is your image in the right Mode?

Most of our plugins work with images in 8-bit RGB Mode. If your image is in another Mode (eg if you just loaded a GIF file or a 16-bit image), you will need to change it to RGB mode first. In Photoshop, this is in the Image menu.

CS4 Image Mode menu

Problems with “Convert for Smart Filters”

Our plugins aren't yet compatible with Photoshop's Smart Filter feature, so if you convert your image with the “Convert for Smart Filters” menu option, Photoshop will hide our plugins from your Filters menu. To re-enable the plug-ins, you will need to right-click on the layer you are working on and click “Rasterize the Layer”.

CS4 Rasterize Layer menu

If you are using 64-bit versions of Photoshop CS4 / CS5

You must use the 32-bit version of Photoshop, even if you have a 64-bit version of Vista or Windows 7. The 32-bit version will run just fine on 64-bit computers.

Check that you have installed the plugins into the 32-bit Photoshop Plugin folder, not the 64-bit folder. The 32-bit plug-in folder path looks like this:

C:\Program Files (x86)\Adobe\Photoshop CS4\Plug-Ins

The x86 part is important. On 64-bit systems, our Photoshop Plug-ins probably won't work if installed into the usual “Program Files” folder. If you've installed it in the wrong place, just uninstall the plug-in, run the installer again and choose the correct Photoshop plugin folder.

Check that you are running the 32-bit version of Photoshop! If you have both versions installed, it can be easy to start the 64-bit version by mistake.

See Also:

Why is the Photoshop Plug-in greyed out? Why can't I click on it?
How to use Photoshop Plugins in multiple programs at once.



<< back to the Support index