Are your Plugins compatible with 64-bit Vista & Windows 7?

Yes! Softener 2 is fully 64-bit compatible!

The newly released Softener 2 has a full 64-bit version that is available for a small upgrade fee. You only need the upgrade if you use 64-bit Photoshop; most other graphics programs are still 32-bit, and the 32-bit version will work on a 64-bit computer just fine.

Yes! If you use a 32-bit graphics program.

Our Photoshop plugins work with Windows Vista and Windows 7, including the 64-bit versions. The key is to use the 32-bit versions of your graphics programs - so if you have Photoshop CS4, you must use the 32-bit version of CS4, not the 64-bit version, or the plug-ins won't work.

The difference between Photoshop CS4 32-bit and 64-bit

When installing Photoshop plug-ins on 64-bit Windows, it's important to use the plug-ins folder in the Program Files (x86) folder. So your Photoshop Plug-ins folder will probably be:

C:\Program Files (x86)\Adobe\Photoshop CS4\Plug-ins\

We have successfully tested Softener 1.30 on Windows Vista SP2 x64 and Windows 7 x64 without any problems. We have also tested with Software DEP enabled on both operating systems, and with Hardware DEP enabled for Vista SP2. We encountered no problems.

While we don't have Mac versions of our plugins, the Windows versions work fine in Boot Camp, Parallels Desktop and VMWare Fusion.

See Also:

Why isn't the Photoshop plugin showing in my Filter menu?
Why is the Photoshop plugin greyed out?
Do you have a Mac version of your Photoshop plugins?



<< back to the Support index